中国分布式计算总站

斯坦福大学主持


分布式计算的定义

2003-11-22 中国分布式计算总站

什么是分布式计算？所谓分布式计算是一门计算机科学，它研究如何把一个需要非常巨大的计算能力才能解决的问题分成许多小的部分，然后把这些部分分配给许多计算机进行处理，最后把这些计算结果综合起来得到最终的结果。 最近的分布式计算项目已经被用于使用世界各地成千上万位志愿者的计算机的闲置计算能力，通过因特网，您可以分析来自外太空的电讯号，寻找隐蔽的黑洞，并探索可能存在的外星智慧生命；您可以寻找超过1000万位数字的梅森质数；您也可以寻找并发现对抗艾滋病病毒的更为有效的药物。这些项目都很庞大，需要惊人的计算量，仅仅由单个的电脑或是个人在一个能让人接受的时间内计算完成是决不可能的。

附图：SETI@home简要原理

此图来自阿根廷SETI网站。Image and Flash comes from SETI@home Argentina.

专业定义 （中国科学技术信息研究所对分布式计算的定义）
分布式计算是近年提出的一种新的计算方式。所谓分布式计算就是在两个或多个软件互相共享信息，这些软件既可以在同一台计算机上运行，也可以在通过网络连接起来的多台计算机上运行。分布式计算比起其它算法具有以下几个优点：
1、稀有资源可以共享，
2、通过分布式计算可以在多台计算机上平衡计算负载，
3、可以把程序放在最适合运行它的计算机上，
其中，共享稀有资源和平衡负载是计算机分布式计算的核心思想之一。
实际上，网格计算就是分布式计算的一种。如果我们说某项工作是分布式的，那么，参与这项工作的一定不只是一台计算机，而是一个计算机网络，显然这种“蚂蚁搬山”的方式将具有很强的数据处理能力。网格计算的实质就是组合与共享资源并确保系统安全。

ENGLISH: What is Distributed Computing?
(http://www.aspenleaf.com/distributed/)
Distributed computing is a science which solves a large problem by giving small parts of the problem to many computers to solve and then combining the solutions for the parts into a solution for the problem. Recent distributed computing projects have been designed to use the computers of hundreds of thousands of volunteers all over the world, via the Internet, to look for extra-terrestrial radio signals, to look for prime numbers so large that they have more than ten million digits, and to find more effective drugs to fight the AIDS virus. These projects are so large, and require so much computing power to solve, that they would be impossible for any one computer or person to solve in a reasonable amount of time.

原作者：equn


分布式计算的意义和格局

2003-11-22 中国分布式计算总站

一、分布式计算与人类

由于现代人类各个课题学科繁多，涉及面广，而分类又细。而当今的每个学科似乎都需要进行大量的计算。天文学研究组织需要计算机来分析太空脉冲（pulse），星位移动；生物学家需要计算机来模拟蛋白质的折叠（protein folding）过程；药物学家想要研制克服爱滋病（AIDS）或非典（SARS）的药物；数学家想计算最大的质数和圆周率的更精确值；经济学家要用计算机分析计算在几万中因素考虑下某个企业/城市/国家的发展方向从而宏观调控。由此可见，人类未来的科学，时时刻刻离不开计算。而分布式计算（Distributed Computing），以其独特的优点——便宜、高效而越来越受到社会的关注。
（想要了解更多有关分布式计算项目的信息请参阅这里）

二、杂乱无章的分布式计算格局

就目前来看，全球的各种分布式计算已有约百种，这些计算大多互无联系、独立管理、独立使用自己的一套软件。目前的这种分布式计算互相割据的格局很不利于发展的需要。比如，某个生物学研究机构需要利用世界各地志愿者的计算机来模拟蛋白质折叠的过程，那个生物学研究机构没有分布式计算方面的专业人才，而但是社会上也并没有任何公司可以提供这样的服务，他们就不得不自己花费大量精力用于开发分布式计算的服务器、客户端。这样一来，原来可以用于研究生物的时间用在了别的地方。刚才提到的生物学研究机构就是美国斯坦福大学的PANDE小组。

三、BOINC一统大局，互相协作！

为了改变这种杂乱无章的割据，美国加州大学伯克利分校（UC Berkeley）首先提出了建立BOINC的想法。BOINC的中文全称是伯克利开放式网络计算平台（Berkeley Open Infrastructure for Network Computing），他能够把许多不同的分布式计算项目联系起来统一管理。并对计算机资源进行统一分配（比方您对研究爱滋病药物和探索地外文明同时感兴趣，您就可以同时选择两个运行，并设置优先级）。对统计评分系统进行统一管理（无论你在为哪个项目工作，只要你奉献CPU时间长，就积分高）。有了这样的统一管理，的确给PANDE小组这样的科学研究机构提供了便利！
由于目前BOINC仍然在测试调试阶段，但是它应该很快能出现在大家的视线中。

讨论

作者：equn


分布式计算在中国

2003-12-6 中国分布式计算总站

分布式计算在中国
2003年12月 写于上海

根据中国互联网信息中心的统计信息，中文网民人数占世界的比重已经增长到了12%左右，并且还在快速增长着。这里所说的中文网民是包括大陆、香港、澳门、台湾和海外华人的。

您也许会问互联网在中国快速发展的原因。我想，主要有以下几个方面。价格便宜：在上海一根512K的ADSL包月才120元人民币左右。教育体制：最近政府花了巨资帮助大学、初高中修建了多媒体信息教室，这使得很多学生对信息技术充满着兴趣和渴望。想要了解更多有关中国互联网的统计信息或发展发展历程，请看这里。
相比于互联网在中国的快速发展，中国的分布式计算却发展缓慢。就我看来，网民数量的统计并不能十分客观地反映一个国家信息化程度的高低，而参与分布式计算网民的数量或比例却可以明显地看出这个国家科学普及化的水平。在这方面，毋庸置疑，欧美国家是十分领先的。在北欧国家，几乎一半的电脑参加了分布式计算项目，这是一个惊人的数字。再让我们来看看我们中国和印度，尽管我们拥有了不少最新科技，且看上去在网络普及化进程中有不错表现，但是在分布式计算方面却很薄弱。让我们来看些例子：

SETI@home是世界上最大的分布式计算项目。从中国的参与人数来看，它在中国也是最著名的项目。它通过使用联网的计算机下载程序分析射电望远镜所收到的讯号，来搜索地球外的生命迹象。
尽管中国在近一年来有所进步，中国的国际排名从29上升到了24，但是我们中国用户却仍然只完成了日本用户完成的工作数的十分之一，而日本，这个高度发达的国家网民人数却少于中国。看来，提高网民素质、提高科学普及化程度也是十分重要的。印度和一些中东国家也有相似的问题，而中欧国家明显在这方面做得比较好，不少独联体国家所完成的数据量已经超过了俄罗斯联邦的总和。

Folding@home是一个研究蛋白质折叠，误解，聚合及由此引起的相关疾病的分布式计算工程。它使用联网式的计算方式和大量的分布式计算能力来模拟蛋白质折叠的过程，并指引我们近期对由折叠引起的疾病的一系列研究。
中国很少有人参加这个项目。

Climateprediction.net工程是把最新的气候预测模型通过家庭、学校、办公室的计算机来进行计算。这些计算完成的结果将会组成世界最大的气象预测模型。气候改变了，而我们对此的行动已经是全球重要的话题。这将影响到人类的农业生产、水资源量、生态系统、能源需求、保险花费和很多其他与人类息息相关的方面。确凿的科学依据表明，地球在在接下来的几个实际可能会变得温暖话，但是我们无法估计到底变化会有多大。如果您参加，这将能有助与21世纪的气候科学预测。

中国目前已经有了很多计算机，其中不乏性能及其先进的。而他们中的大多数仅仅是打字、播放幻灯而已。这不能不说是一种资源的浪费。
从另外一个角度看，我们不难发现发达国家和发展中国家的差距。我们把这种现象称为数字鸿沟。另一个现象同样令人痛心疾首，所有的分布式计算项目都是由发达国家发起的，这一方面也加深了科学鸿沟。斯坦福大学化学系的戈尔哈姆•理查德•切尔曼教授说，分布式计算将加快整个人类的科学进程。科学家们现在可以完成以前从来想不到要去完成的，或者要花几十年几百年才能完成的计算任务。这是的确是千真万确的，但是这种计算从一定程度上助长了发达国家的科学垄断。
幸而，中国有关部门也开始意识到分布式计算的重要性，一些大学教授和科学家也开始钻研分布式计算科学。以下是相关的一些链接。
政府当局：
网格运算成为上海市政府的新名词解释之一（给出中文定义）；
网格计算讲座报告（中国教育与研究网）
研究小组和科学家：
清华大学的刘鹏小组（包含大量分布式计算的中英文信息）
清华大学网格研究小组（研究如何实现一个分布式计算项目）
华南理工大学高性能网格计算平台（架设分布式计算平台）
网格中文网（目标成为最大的网格计算中文资料中心）

作者：equn


Folding 科学

了解最新情况清访问英语页面。

感谢上海市进才中学生物组的翻译纠正。

什么是蛋白质？

蛋白质是由氨基酸分子形成的长链。蛋白质是生物生存的基本条件。作为酶, 他们是所有生物化学反应的驱动力。作为结构的基本成分,它们是我们的骨骼、肌肉、头发、皮肤和血管的主要组成部分。作为抗体，它们可以识别入侵物体，使免疫系统工作从而清除这些物体。因此, 科学家对人类的基因组进行排序——生物圈蛋白质蓝图——但我们怎样可以了解这些蛋白质做了些什么？它们又是怎么运作的?

*看看UD计算的蛋白质照片。

关系到人的染色体项目

蛋白质在生物学中充当如此重要的（原文为根本性）角色, 科学家开始对人类的基因组开始排序。基因组实际上是一张跟蛋白质有关的“蓝图”——基因组包含遗传密码（DNA Code），这些密码决定着氨基酸串成蛋白质长链的顺序。

蛋白质为什么“折叠”？

但是, 仅仅了解基因组序列并不能使我们充分了解蛋白质的工作，更无法了解它是如何工作的。为了发挥它的功能作用（比方作为酶和抗体），他们必须具有非常特定的形状, 亦称“折叠（Fold）”。蛋白质犹如一台令人惊奇的机器: 在他们进行工作之前, 他们自己组装自己! 这种自我装配被称为“折叠（Folding）”。

我们项目的目标之一是模仿蛋白质折叠，从而了解蛋白质是如何那么迅速可靠地折叠的，并了解如何使用这些蛋白质的属性来制造高分子聚合物。折叠模仿结果的影片可以在这里找到。

蛋白质折叠和相关疾病：
疯牛病、阿兹海默氏症

如果蛋白质没有正确地折叠将发生什么？比方阿兹海默氏症(Alzheimer's)、囊肿纤维化（Cystic fibrosis）、疯牛病(Mad Cow, BSE), 一种遗传的肺气肿, 甚至许多癌症的起因都是蛋白质的非正常折叠。

当蛋白质非正常折叠，可能凝聚起来(“集合体”) 。这些凝聚物可能经常聚集在脑子里，这就是现在通常认为导致阿兹海默氏症和疯牛病的病因。

蛋白质折叠和纳米技术:建造纳米级的仪器！

除生物医学的应用之外，了解蛋白质的折叠同时也将教会我们应该如何设计我们自己的、像蛋白质大小的“纳米仪器”进行相似的工作。当然，在纳米仪器可能执行任何任务前，他们也必须进行组装。

为什么蛋白质折叠那么难搞清？

最令人惊讶的不仅是蛋白质本身能够自我组装——折叠，而且是它们自我组装的速度是如此之快:一些蛋白质能够在百万分之一秒之内完成自我折叠。虽然这个时间在人的时间表中是非常快的，但是用计算机进行模拟，这个时间就显得相当长了。实际上，计算机模拟1纳秒（1/1,000,000,000秒） 需要花费大约一天的时间。不幸的是，蛋白质折叠是以数十毫秒（10000纳秒）作为时间表的。这样，这将需要10000台计算机花费数天的时间来模仿折叠。——例如，这将需要30台计算机花费数年的时间。这样等一个结果出来需要的时间太多 。

一种解答：分布动力学

要解决蛋白质折叠的问题，我们需要冲破微秒障碍。我们的小组开发了一种新的模仿蛋白质折叠的方式——一种“将工作单元分解成多个部分，使用多台处理器来模拟”的办法来冲破毫秒障碍。因而，有1000个处理器, 我们就能冲破微秒障碍从而帮助了解蛋白质是如何折叠的奥秘。

我们到目前为止做了什么？我们将做什么？

http://foldingathome.stanford.edu/是成功的。在从2000年10月到2001年10月的一年内，我们已经使用了我们实验性检验的方法折叠了一些小且快速被折叠的蛋白质。我们现在正在进一步开发我们的方法，并推广到模仿折叠一些更加复杂、更加有趣的蛋白质和“蛋白质正常折叠与非正常折叠”的问题。您能从我们的结果页上了解更多。

我怎么可以了解更多关于 Folding@Home 的信息？

一个了解我们如何成功运作Folding@Home 1.0以及Folding@Home是怎样工作的好地方是我们的论文或最近的刊文。我们最近刊在《物理概览新闻(Physical Review Letters)》的论文描述了我们模拟折叠方法的依据，并从数学角度论述了使用千万台个人计算机千万次加速模拟折叠的可行性。我们最近刊在《分子生物学学报(The Journal of Molecular Biology)》的论文具体地谈论了我们如何将模拟折叠蛋白质的方法从第一个结果推广运用到别的蛋白质中。

Folding@home客户端(命令行或屏幕保护程序)显示进行蛋白质模拟的实时图形。图像中的分子是当前正在被模拟折叠的原子，蛋白质 在您的计算机中进行模仿折叠。

当折叠的本质由序列确定, 它被输入以非常复杂的方式。 因而, 蛋白质可折叠能看作为连接在染色体(序列之间) 并且什么蛋白质实际上(他们的作用) 。

进一步探索: 其它站点的有趣的链接 (English)

学会更多关于脱氧核糖核酸（DNA）、染色体、 蛋白质、折叠， 我们建议您访问以下的链接(被推荐的链接黑体字):

SIMULATIONS OF PROTEIN FOLDING:
  • Challenge Of Showing How Proteins Fold (The Scientist Magazine)
  • Shape is all (New Scientist Magazine)

DNA:
  • DNA as a method for fingerprinting
  • DNA learning center
  • The Biology project: molecular biology
BIOLOGY OF PROTEIN FOLDING:
  • Database of interesting proteins
  • Relevance of protein folding (protein folding summary by IBM)
  • Unraveling the Mystery of Protein Folding (FASEB Journal)
  • Research groups interested in protein folding
  • Molecules of Life
GENOME PROJECT:
  • New York Times Special Coverage on the Genome. Includes many artiles, movies, diagrams on DNA, proteins, and genetics. (free registration, but required)
  • National Human Genome Research Institute (NHGRI)
  • Whitehead Institute for Biomedical Research
NANOTECHNOLOGY:
  • Nanotechnology

BIOTECHNOLOGY:
  • National Center for Biotechnology Information (NCBI)
PHYSICAL CHEMISTRY:
  • Physical Chemistry on the web
  • Physical chemistry of making fudge
BIOCHEMISTRY:
  • Biochemistry on the web
  • The Biology project: biochemistry
WHAT THE PRESS IS SAYING ABOUT FOLDING@HOME:
  • Protein Fiends Join the Fold (Wired News)
  • National Public Radio (NPR)
PRESS ARTICLES ABOUT THE PANDE GROUP'S RESEARCH:
  • Challenge Of Showing How Proteins Fold (The Scientist Magazine)
  • Shape is all (New Scientist Magazine)


UD计算中的蛋白质图片欣赏

如果想知道更多有关蛋白质的信息，可参考其他与生物化学相关的书籍。

C-ABL酪胺酸激脢(位于染色体9q34) C-ABL Tyrosine Kinase | 周期素依赖性激脢-2 Cyclin Dep. Kinase -2 | 环氧合酶-2 cyclooxygenase-2
法尼酯转移酶 Farnesyltransferase | 纤维母细胞成长因子受容体 Fibroblast GF Recept | 组织蛋白酪氨酸磷酸酶 Prot-Tyr-Phosphatase
丝氨酸/苏氨蛋白激酶 RAF | 抗伤寒沙门菌，超氧化物歧化酶 Superoxide dismutase，SOD | 酪胺酸激脢(Q3) Tyrosine Kinase (Q3)
血管内皮生长因子 VEGF | 炭疽 Anthrax | 您还知道其他的? 告诉我


了解蛋白质折叠、聚合以及相关疾病的分布式网络计算

什么是蛋白质？它们是怎么折叠的呢？蛋白质是一个生物体系的网络基础，它是一个个纳米级计算机。在蛋白质实现它的生物功能之前，它们会把自己装配起来，或者说是折叠；虽然蛋白质折叠对所 有的生物来说是最基本的和最明确的事实，但它的折叠过程对人类而言仍然是个未解之谜。此外，当蛋白质没有正确的折叠（误折）无疑会产生严重的后果，包括许多知名的疾病，比方阿兹海默症(Alzheimer's)，疯牛病(Mad Cow, BSE)，可传播性海绵状脑病(CJD)，肌萎缩性脊髓侧索硬化症(ALS)，还有帕金森氏症(Parkinson's)。

Folding@home是如何工作的呢？Folding@home是一个研究蛋白质折叠，误解，聚合及由此引起的相关疾病的分布式计算工程。我们使用联网式的计算方式和大量的分布式计算能力来模拟蛋白质折叠的过程，并指引我们近期对由折叠引起的疾病的一系列研究。

上图为绒毛素模拟的结果

UD计算的蛋白质图片欣赏

您可以为我们做什么？您可以下载并运行我们的客户端程序。我们的程序是这样的，更多的计算机加入此工程，此工程计算的速度就越快。

到目前为止我们做了什么？我们已经有了几个成功的例子。您可以阅读我们的教学页、结果页，或者直接去我们的研究中心。

如果您有其他问题，请访问我们的论坛。

感谢“精品网址大全”提供网站空间。

从2000年10月1日起,世界各地有400,000个CPU参加了Folding@home。 国家列表请看这里。

FOLDING@home的其他语种翻译：


常问问题

常问问题(常见问题解答)——(2003年5月19日最后更新)
*为了让您快速直接地搜索到您需要查询的内容，可以使用“编辑”菜单中的“搜索”功能。

*本页面由VMZY和王轶群共同翻译。

*没有授权，不得转载，但是可以链接。谢谢。

*如果觉得翻译有问题或者有不明白的地方可以去我们留言板。

*省略：F@H表示Folding@home, G@H表示Genome@home。

了解最新情况清访问英语页面。

标题:

  • 项目细节，概览
    - 什么蛋白质折叠？
    - 谁“拥有”结果？ 他们将会得到什么？
    - 共有多少人参与了？到目前为止有哪些蛋白质被“折叠”了？到目前为止我折叠了多少？
    - 为什么不公布源代码？
    - 项目到目前为止完成了多少？
    - 为什么不在超级计算机上运行？
    - http://www.equn.com/folding/faq.htm#1.7

  • 网络问题
    - http://www.equn.com/folding/faq.htm#2.1
    - http://www.equn.com/folding/faq.htm#2.2
    - 我有多台机器在防火墙下运行。 他们都可以用同样用户名吗？

  • 错误
    - http://www.equn.com/folding/faq.htm#3.1
    - http://www.equn.com/folding/faq.htm#3.2
    - 我的屏幕保护程序看起来象一个有许多小点漂浮的黑屏幕。它显示的到底是什么？
    - Windows请求某一个DLL文件 。 我在哪里可以找到它？
    - 遇到一个错误：当我设法下载时“Format:MyForm not found”。
    - 遇到一个错误：在命令行版本(或在文件scrlog.txt*) 中出现“Network Recv Timeout(网络接收超时)” 。
    - 遇到一个错误：在命令行版本(或在文件scrlog.txt)中，出现“Running self tests.......test failed, error-1(自我调试中……调试失败，错误-1)” ，但是后来程序却看似运行正常。
    - 遇到一个错误：在命令行版本(或在文件scrlog.txt)中，出现“Running self tests.......test failed, error-1(自我调试中……调试失败，错误-1)” ，后来程序没有响应。
    - 当我运行屏幕保护程序时，它没有响应，显示出现页面错误。
    *该文件为记录命令行版本程序的命令、反馈等历史资料的文本文档。

  • http://www.equn.com/folding/faq.htm#4.0
    - http://www.equn.com/folding/faq.htm#4.1
    - 我是否可以选择其中一个、选择优先运行一个项目、或运行两个？
    - 为什么要合并两个项目的客户端程序？

  • 运行
    - 我完成了一个数据包但我现在又得到了运算同一个蛋白质的数据包。这是一个错误吗？
    - http://www.equn.com/folding/faq.htm#5.2
    - 在局域网上运行需要做什么特别的设置吗？
    - http://www.equn.com/folding/faq.htm#5.4
    - 如何在Windows已经正式启动，但是还没有登录的状态下自动运行屏幕保护程序？
    - 结果怎么传回到您那里？
    - 我每次可以下载多个数据包吗？
    - 完成一个数据包一般需要多长时间？
    - 我可以同时运行屏幕保护程序和命令行版本吗？ 如果我同时运行两个命令行程序会出现什么问题？
    - 我怎么可以知道我的结果是否被接收到？ 我如何知道我计算了多少个数据包？
    - 为什么通过调整任务管理器的进程优先权并不会影响计算速度？我怎么手工调整进程优先权？
    - http://www.equn.com/folding/faq.htm#5.x2
    - 对每个数据包的计算时间有限制吗？
    - 我可以在Free-BSD上运行Linux版本客户端吗？
    - 什么是模拟的不稳定性？

  • 统计、用户名 、小组等等
    - 我怎样更改我的用户名？
    - 我怎样加入或建立一个小组？
    - 我有多台机器在防火墙下运行。 他们都可以用同样用户名吗？
    - 在用户名中我应该避免上使用哪些字符？
    - 您如何决定一个数据包有多少积分？
    - 您如何设定最后期限？
    - http://www.equn.com/folding/faq.htm#6.7

  • 屏幕保护程序问题
    - 我应该使用屏幕保护程序还是命令行版本？
    - 屏幕保护程序显示的是什么？
    - 我的显示器被设置成一段时间后关闭。在这种情况下我仍然能运行屏幕保护程序吗？
    - 屏幕保护程序使用很多CPU资源吗？
    - 3D硬件加速会额外帮助屏幕保护程序更快吗？
    - 我怎么关闭屏幕保护程序？

  • 其它
    - 标志来自何处？
    - http://www.equn.com/folding/faq.htm#8.2
    - 您是否有专用的网络链接（用来链接官方网站）图片下载？
    - 安全问题？
    - 为什么没有IRIX/Solaris/其它版本？
    - 您将在软件的最新版本中增加什么功能？ 回顶

回答

  • 项目细节，概览:

    什么蛋白质折叠？
    请看见我们“科学”部分来了解详情。回顶

    谁“拥有”结果？ 他们将会得到什么？
    不同于其它分布式计算项目，Folding@Home是由科研机构开办的(主要是斯坦福大学 化学系的Pande小组，)，是一个致力于科学研究和教育的非盈利性机构。我们不会出售数据或用它它们来挣钱。
    而且，我们将把数据无偿的献给其他人使用。特别要注意的是，Folding@Home的结果将可以从很多方法获得。我们主要将模拟的分析结果递交给学术报刊出版，而这些期刊文章在出版后将被张贴在网页上。 其次，在这些分析数据的科学文章出版以后，折叠的源数据将无偿给大家使用，包括在这个网站里的其它研究员。回顶

    共有多少人参与了？到目前为止有哪些蛋白质被“折叠”了？到目前为止我折叠了多少？
    我们将各种类型的用户统计和已完成的项目保留在我们的网页上。您能查看个人统计，团队统计，和项目整体统计。回顶

    为什么不公布源代码？
    我们只能适当地公布我们的代码。更多信息将随后而来。不同于其它计算机项目，我们所应该关心的不是功能，而是科学的正确性，完全公布源代码将会给一些人反编译代码并伪造科学结果，这会使整个项目毫无意义。回顶

    项目到目前为止完成了多少？
    (至2002年6月)根据我们的折叠动能学的实验性结论我们能在5-10微秒时间范围折叠几个蛋白质。 与以前的工作相比这是根本的进步。 我们的结果的科学论文详述可以在“论文页（英文）”上找到。 我们现在正转向其它的在折叠的结构生物学研究方面十分重要的蛋白质，比如与疾病相关的蛋白质。回顶

    为什么不在超级计算机上运行？
    现代巨型计算机基本上就是由高速的网络连接起来的一小群处理器。这些处理器的速度与个人计算机里的CPU速度相比差不离(而且一般还要慢一些) ! 因而，如果一个运算(象我们的)不需要快速的网络，那么它依然可以像巨型计算机那样在超大群的处理器高速地运行。但是，我们的应用程序需要的不止是现代巨型计算机里的几百个处理器，而是数以万计的处理器。 因此，是不可能的通过任何其它方法来完成Folding@Home的计算任务的! 而且，既使我们被给予了世界上所有的巨型计算机的使用特权，我们的Folding@Home处理器数目与现今的方式相比仍然很少! 这是可能的，因为现在个人计算机处理器是非常快速的，并且在世界上有成千上万台的个人计算机正空闲着。回顶

    我可以在别人的机器上运行Folding@Home吗？
    请在您或者经机器所有者的允许的机器上运行我们的软件。把Folding@Home用在其它方面会违犯我们的使用协定(总的来说那不是一个好想法)。回顶

  • 网络问题:

    拨号上网也能使用Folding@Home吗？
    可以。它可以被设置为自动地拨号，或闲置等待直到您手动连接。不过拨号上网和屏幕保护程序版本可能会出现一些问题。如果您遇到了这样的问题，请使用Folding@Home的命令行版本。 回顶

    我可以在运行Folding@Home的同时使用防火墙吗？
    可以。请在设置栏里设置您的防火墙或代理服务器。 您可以在图形显示界面点击右键或点击任务栏图标进入设置栏。回顶

    我有多台机器在防火墙下运行。 他们都可以用同样用户名吗？
    可以。他们都可以有相同的用户名。
    必须要指出的是，以前您必须再用户名后加上#1,#2..现在已经不再需要这样做了！谢谢。    回顶

  • 错误

    Folding@Home的Windows安装程序为什么不工作了？
    如果您在安装Windows版的图形客户端或屏幕保护程序版时，看见"Setup is starting..."出现，然后失去响应(甚至没有提示错误信息) ，问题可能是由在您的安装文件夹里出现被命名为“setup.exe”的文件所引起的(可能出错的文件夹是F@h的安装文件所在文件夹，您的桌面，您的临时文件夹)。记住，根据您的操作系统而定，您可能有多个临时文件夹。删除或移动setup.exe文件，那么安装就应该可以正常进行了。回顶

    Folding@Home 看起来有问题(Windows下)或在Linux出错(segfaults)
    Folding@Home 要求至少32 MB RAM 。 在Windows操作系统中出问题一般只会在内存不足的情况下发生，在Linux的命令行客户端只有在内存不足的情况下才会出现一些简单的segfaults。回顶

    我的屏幕保护程序看起来象一个有许多小点漂浮的黑屏幕。 显示的到底是什么？
    我们已经解决了这个问题。它是由不支持8位颜色的显示器或显卡造成。同时，我们发现有些老显卡的驱动程序有问题。 如果您有这种问题，请把您的显卡和OpenGL驱动升级到最新版。回顶

    Windows请求某一个DLL文件 。 我在哪里可以找到它？
    在微软的站点有这些DLL文件。特别需要说明的是，主流操作系统比如Windows NT，98，和2000安装时自动安装了winsock2和OpenGL的一些DLL文件。 但是，旧的系统比如Windows95中没有这些。
    Windows95的winsock2升级解决了一些的Winsock2问题。 这次更新也解决了一些的TCP/IP堆栈问题。
    在Windows95 OSR 2零售版中包含了win95的OpenGL 1.1。 它的自解压文件可以在微软的ftp站点下载ftp://ftp.microsoft.com/softlib/mslfiles/opengl95.exe。它包含在Win95下运行OpenGL程序所必须的文件opengl32.dll。 回顶

    遇到一个错误：当我设法下载时“Format:MyForm not found”。
    这好像是斯坦福的服务器而不是我们的计算机有问题，并且我们正在设法确认问题的确切的起因。这种情况时是相当罕见的，然而，我们建议您可以等一会儿后再试一试。回顶

    遇到一个错误：在命令行版本(或在文件scrlog.txt) 中出现“Network Recv Timeout(网络接收超时)” 。
    如果您遇到如下情况:
    > Deleting files IP = 171.64.122.81
    > Network Recv Timeout
    > GetWork Failed
    不要担心。这是连接到服务器有问题，它正在等待再尝试。 我们现在有几个服务器问题，并且许多用户有同样问题。 请等待一阵子，它将自动连接。 如果它一天都连接不上，您最好将程序重新启动或重装。 对命令行版本而言，按住Cntl-C安全退出(注: 最近增加了这个功能，因此它不一定适用于您当前的版本，您必须强行关闭它) ，然后再次运行。回顶

    遇到一个错误：在命令行版本(或在文件scrlog.txt)中，出现“Running self tests....test failed, error-1(自我调试中…调试失败，错误-1)” ，但是后来程序却看似运行正常。
    不要担心，如果它看起来还在正常工作，那么它没有出错。这个错误信息是Folding@Home程序中的Cosm分布式计算程序的一部分。如今我们能够告诉您，它并不影响Folding@Home程序的正常运行。回顶

    遇到一个错误：在命令行版本(或在文件scrlog.txt)中，出现“Running self tests....test failed, error-1(自我调试中…调试失败，错误-1)” ，后来程序没有响应。
    卸载，并保证在"Program Files"文件夹里的Folding@Home文件夹被完全删除了，然后重装。一般来说，这样应该管用。 回顶

    当我运行屏幕保护程序时，它没有响应，显示出现页面错误。
    如果您遇到如下情况:
    > The error message reads FOLDINGATHOME caused an invalid page fault in module FOLDINGATHOME.SCR at 015f:00420494.
    然后出现无穷多的对话框让您点击，这是因为屏幕保护程序开始时内存不足。 建议当屏幕保护程序运行时关闭其它应用程序，并把等待时间设置长一些(5—10 分钟) ，这么一来，当您在工作时屏幕保护程序就不会运行。回顶

  • Folding@Home和Genome@Home

    什么是Genome@Home？它与Folding@Home项目和Folding@Home科研有什么关系？
     http://genomeathome.stanford.edu/是斯坦福大学Pande实验室的另一个分布式计算项目。 您能在http://genomeathome.stanford.edu/上看到更多详细资料，但简要地说，Genome@Home的目标是蛋白质设计和它的应用。 我们设计蛋白质的一个主要应用就是创建设计蛋白质序列的大资料库，实际上是“再设计” 或“反编译” 一条现有的染色体(因此命名"Genome@Home") 。
    蛋白质设计的另一个应用是将了解蛋白质为什么折叠，他们为什么会“误折”和聚合。 这是Folding@Home的一个主要问题，与我们的对于蛋白质折叠和“误折”的研究有直接地联系，事实上它与“误解”相关的疾病也有关，譬如阿兹海默症、肌萎缩性脊髓侧索硬化症等等。回顶

    我怎样能选择F@H 或G@H ，要设置一下，还是让客户自动选择？
    我们客户端很有灵活性。 特别是：其一，只想要参与其中的一个项目；其二，想要同时参加两个计划但是在计算机资源分配等问题上选择一个优先项目；其三，想要把计算量贡献给当时最需要帮助的项目。因此，客户端是可选择的。如果您选择了一个G@H组，您将参加G@H。如果您有偏爱其中的一个，那么您可以在客户端里选择您喜欢的那个。如果您不在意，可以保留默认值。如果您选择了一个项目(例如G@H)却得到了另一个项目的数据，那肯定是出错了，我们将设法修正它。 我们知道这很重要。 长期以来我们一直在设法合并我们的这两个项目的程序框架以便简化服务器端的工作，并让我们更灵活地进行科学研究。 我们了解统计的重要性，并按如上所述的一直在进行不懈努力。
    这里要特别说明的是，如果您打开了“advmethods（Advance Methods, 高级方法）”选项，得到了我们的最新的解码程序和数据包，这将忽略您的所有选择设置。回顶

    为什么合并二个项目的客户端程序？
    尽管我们的项目属于生物科学范畴，但是既然我们在用分布式计算来实现就一定离不开分布式计算的科学。我喜欢让我的小组把时间投入到科学上，而不是管理一个分布式计算系统。如果用一段基础程序实现两个项目，而不是两段完全不同的程序，这将简化了我们的工作，因此合并他们。这将使我的小组能够集中精力搞科学研究。回顶

  • 运行

    我完成了一个数据包但我现在又得到了运算同一个蛋白质的数据包。这是一个错误吗？
    不，一切正常。 我们对一些蛋白质进行动力学研究，因此您可能对同样蛋白质计算多次。 每个数据包都会提供给我们关于那个蛋白质的动力学方面的更多信息，这对我们很重要。 的确，如果我们只把每蛋白质计算一次，我们是不会研究出什么东西来的。 回顶

    Folding@Home可以在双处理器的机器上工作吗？
    可以。另一个处理器必须运行命令行版本(如果在Windows上运行要加上"-local"参数命令)。首先，要给每个处理器建一个单独的文件夹并把FAH3Console可执行文件拷贝到每个文件夹。 然后用-switch命令设置每一个命令行程序。最重要的是，要确保在"高级设置" 选项中给每个拷贝分配一个独立的机器ID号(从1 到4) 。 第一拷贝将默认为机器ID 1 ，因此其它的拷贝应该被设为ID2，3和4。然后在Windows系统上用-switch参数就可以从每个安装文件夹里启动它们。为此您应该用您的系统提供的任何工具(比如Windows系统的任务管理器)给每个处理器分配一个进程。
    我们正在使用OpenMP开发一个含有并行处理的代码多处理器版本。但是，我们发现, OpenMP的并行处理代码有些问题，因为它和我们的代码里的处理器编号有冲突。因此我们正在开发新的并行处理程序，不过并行处理器版本的发布日期仍是一个未知数。回顶

    在局域网上运行需要做什么特别的设置吗？
    最主要的是要保证，为了防止ID冲突，给每台机器分配一个独立的CPUID。Windows版本(v.3或更新版本)把ID列表保存在注册表里，Linux版本(v. 3.11或更新版本)把它保存在专用文件MachineDependent.dat中 。
    ·避免ID冲突的方法:
    1) 如果您在每台计算机上都各自独立安装客户端程序，那是不可能会出现ID冲突的。
    2) 如果您使用的是最新版的Windows或您的机器只有一个CPU，您也不会遇到这类问题(如果是双处理器，请看前面的介绍) 。
    3)如果您使用的是Linux域，记住，当您复制文件夹时，不要复制MachineDependent.dat文件。客户端运行时会自动产生这个文件来保存新ID号。回顶

    为什么我应该把我的Folding@Home软件更新到最新版？
    我们一直在不断地改进Folding@Home软件。 我们发布新版本来修补由用户报告的漏洞，以保证项目尽可能地顺利进行。回顶

    如何在Windows已经正式启动，但是还没有登录的状态下自动运行屏幕保护程序？
    即使在没人登陆时让屏幕保护程序自动运行，以便更加有效的利用CPU空闲时间。为此您必须编辑Windows注册表。您可以使用regedit程序(或win2000 里的regedt32) ，通常位于C:\Windows文件夹。 如果它不在那里，您可以用开始菜单里“搜索”工具找到它。 这样做也许会需要您有管理员权限。 如果您没有管理员权限，那么尝试说服管理员这样做:)
    当您运行regedit后，按HKEY_USERS文件夹旁边的加号打开它。 然后打开.DEFAULT文件夹下的.Control Panel文件夹下的DESKTOP文件夹。 选择.DESKTOP文件夹。在右手边窗口里您应该可以看到一列名称和数据。 选择ScreenSaveActive，单击鼠标右键，选择修改。键值应该被设置为1。 这将使屏幕保护程序在没人登陆时自动运行。然后选择SCRNSAVE.EXE，将它改为winfah.scr 。(最好把它设置为绝对地址，比如C:\Windows\winfah.scr——无论它在哪里) 。这就把Folding@Home屏幕保护程序改为了当没人登录时运行的缺省屏幕保护程序。最后，选择ScreenSaveTimeOut把它改到60。 这杨，屏幕保护程序在某人注销之后会及时地运行(实际上是60 秒) 。
    总结，设置成在没人登陆时自动运行屏幕保护程序，更改注册表键值:

    键名

    键值

    HKEY_USERS\.DEFAULT\ControlPanel\Desktop\ScreenSaveActive

    1

    HKEY_USERS\.DEFAULT\ControlPanel\Desktop\SCRNSAVE.EXE

    winfah.scr

    HKEY_USERS\.DEFAULT\ControlPanel\Desktop\ScreenSaveTimeOut

    60 回顶

    结果怎么传回到您那里？
    每当您的计算机完成了一个数据包，它会自动地将结果上传到我们的服务器，同时会下载一个新的数据包。如果您的计算机只是偶尔地连接到互联网，那么此时，也许会出现问题。 我们正在努力使我们的程序更好的适应这种情况。只有命令行版本在使用调制解调器连接时，偶尔会出现一些错误。回顶

    我可以每次下载多个数据包吗？

    如果大家每次下载一个数据包，并且在各个数据包完成之后上传，我们的统计算法将会工作正常，因此您无法选择下载多个数据包。 如果在您的计算机里有多个处理器，那么不同的处理器可能在算不同的数据包；看看这里我们该什么做. 也不要在不同的机器上运行使用同样目录同样文件系统的两个相同的复制，——他们需要在不同的目录下运行。回顶

    完成一个数据包一般需要多长时间？ 您怎么评定一个数据包的时间限制？
    毫无疑问，根据计算机的速度和所研究蛋白质的大小的不同，这个时间是不同的。 根据蛋白质和研究性质的不同，使用的数据包的大小也不尽相同。 项目 总体统计里有关于个别蛋白质的大小和为其分配的完成期限的详细信息。 回顶

    我可以同时运行屏幕保护和命令行吗？ 如果同时运行两个命令行程序会出现什么问题？
    您必须把他们安装到不同的目录。同时，请千万不要在目录间互相拷贝文件。这将导致我们的服务器混乱，同时您您所计算完成数据包将被视为无用数据，从而无法得到您的统计积分；而且这对科研毫无用处。最好把安装程序运行两次装入不同的目录。如果您想把程序复制到不同的文件夹里运行，那么找到client.cfg 文件并删除"userid=xxxxxxxx"一行。它下次连接到F@H的时候，它会重新设置client.cfg文件，这样就一切正常了。回顶

    我怎么可以知道我的结果是否被接收到？ 我如何知道我计算了多少个数据包？
    欲知您的结果上传情况，你可以查看个人统计,小组统计，和整体项目统计. 如果您的计算机收到返回的统计数据，您应该可以在您的用户名旁边看到您已完成数据包的个数。 如果里面没有您的名字，并且您的屏幕保护程序或命令行版本程序工作正常，那么可能是因为它连一个数据包都没有算完(这可能需要几天，机器越旧需要的时间越长) ，列表还未被更新。 一两天后再看看，它应该就在里面了…… 只要您正确地记住了您键入的用户名是什么:) 回顶

    为什么通过调整任务管理器的进程优先权并不影响计算速度？ 我怎么手工调整进程优先权？
    目前用户通过winNT/2000/XP的任务管理器设法改变进程的优先权这不影响它的计算速度。原因是, 计算工作是由CPU内核线程完成的，它被设定为在空闲时运行，且不受进程优先权影响(默认为'normal') 。 为了手工改变优先权用户必须使用允许修改内核线程优先权的程序。回顶

    可以和同时SETI@home运行吗？
    可以，假设您有足够的系统内存，SETI@home和其它分布式计算程序可以Folding@Home一起运行。 一些程序，包括SETI@home的进程权限比Folding@Home高，如果它们同时运行，Folding@Home将停止计算。如果您发现Folding@Home不工作，您可以在Folding@Home的Windows版本的的advanced option（高级选项）界面里选择"Slightly Higher Priority"来解决这个问题，或通过命令行版本的"FAH2Console -config"来修改。回顶

    对每个数据包的计算时间有限制吗？
    是的。依靠在工作单位，未到期完成的数据包会被再分配给其它计算机。 因为新数据包是由已完成的老数据包所产生的，我们用数据包过期机制保证项目的顺利进行。当数据包比较大时我们会尽可能的延长过期时间。 例如，现在我们给绒毛素分子使用3天的失效时限。不少数据包的失效时间更短。您将从您完成的所有数据包中得到积分(既使他们到期了)，但从科学角度来讲，他们没有任何价值。 回顶

    我可以在Free-BSD上运行Linux版本客户端吗？
    是的，请按照下列步骤来做：
    >从FreeBSD的安装盘上选择安装emulators/Linux_base；
    >修改/compat/Linux/etc/yp.conf，把正确的服务器放在那里；
    >下载linux版本的客户端程序，并定位到该目录；
    >对客户端程序执行“% brandelf -t”命令；
    >如果您运行3.24版本，你在运行客户端之前必须指定“-freebsd”标记；
    >程序将自动载入科学程序核心，下载开始。
    ·在3.24版本之前，“-freebsd”标记并未被设计如程序，您必须按照以下步骤来做：
    >在启动客户端程序后，在下载勒科学程序核心之后强行中止程序，并打入以下命令：
    >“% brandelf -t Linux FahCore_65.exe”
    >“% ./FAH3Console”
    那么一来您就完成了设置！（感谢“gotti”的好主意！）回顶

    什么是模拟的不稳定性？
    分子运动的模拟包含着巨大的计算量。每一个动作由不少时间间隔组成（每一个间隔都很小）。每一个时间间隔，各种原子的位置都要基于一些因素来被计算并更新。有些时候，模拟程序还会算出不合情理的结果（比方原子之间距离过于靠近，化学键键角出于不可能的角度等等）。碰到这样的情况，核心程序会自动退出，所有的信息将被上传到服务器，而客户端程序会再自动得到另一个任务。如果您的计算机是稳定正常的，您并没有什么错失。在非稳定的计算机上，模拟的不稳定性的原因一般是由于系统的一个错误导致的，而数据包内部出现错误的概率却比较小。正因为这样，我们时常重复发送那些出现异常的数据包，我们认为这些重复发送的异常数据包中只有一小部分被确认为真正的不稳定。回顶

  • 统计、用户名 、小组等等

    我怎样更改我的用户名？
    最简单的更改用户名的方法是去控制面板（右击程序图形显示区域，或者单击任务栏中的小图标）。您可以随意修改您的用户名。但是，以前的数据包仍然会以旧用户名的名义来统计。回顶

    我怎样加入或建立一个小组？
    要建立一个小组，请填写这张表格。要加入一个小组，只要把小组的标号填入控制面板（使用图像操作界面时），或者在第一次运行的时候填入小组编号（命令行版本）。回顶

    我有多台机器在防火墙下运行。 他们都可以用同样用户名吗？
    可以。他们都可以有相同的用户名。
    必须要指出的是，以前您必须再用户名后加上#1,#2..现在已经不再需要这样做了！谢谢。回顶

    在用户名中我应该避免上使用哪些字符？
    我们强烈建议您仅仅使用拉丁字母、阿拉伯数字和下划线。现在，我们也接受“#^~|”。“#”被用作区分局域网内计算机（见上方）。我们同时也接受了一些其他的字符来应对可能出现的问题。回顶

    您如何决定一个数据包有多少积分？
    在发送一个数据包前，我们用一台不支持SSE或3DNow的500MHz的赛扬处理器来衡量这个数据包所需要的处理天数。并按照以下公式：
    积分 = [2] 乘以 [乘数] 乘以 [处理一个数据单元所需要的天数]回顶

    您如何设定最后期限？
    在发送一个数据包前，我们用一台不支持SSE或3DNow的500MHz的赛扬处理器来衡量这个数据包所需要的处理天数，然后把天数乘以2.5。这意味着一台同样配置的电脑至少要每天运行10个小时来达到这个期限。就我们的经验来看，大多数参与者的计算机超过了我们这台标准计算机，所以说这完全不是一个问题（如果您所使用的计算机比我们的标准计算机还要慢，您每天就必须延长计算机的工作时间）。有时，最后期限会被适当拖后，实际上我们设置最后期限本身的原因是希望尽早得到运算结果来应用于我们的科学项目。我们正在研究，在不久的将来，计算机的运行速度将记录在账号中，这样一来，运算速度比较慢的机器将会被分配到比较小的数据包。回顶

    怎样处理Folding@Home 1.x的统计数据？
    新的2.x版本在各方面有了很大改进，而统计系统有了改动。正是因为这些大幅度的改动，旧的统计系统不再兼容，每位用户将从新的2.x版本开始统计。回顶

  • 屏幕保护程序问题：

    我应该使用屏幕保护程序还是命令行版本？
    图形操作版本所显示的内容和屏幕保护程序一样，只不过显示区域仅仅限于窗口中。
    ·您应该在以下情况下使用图形操作版本：
    >希望一直在后台运行Folding@Home；
    >不希望使用屏幕保护程序；
    >想了解自己的电脑到底在模拟什么。
    ·您应该在以下情况下选择“仅仅使用屏幕保护”。
    >不希望让Folding@Home一直在后台运行，仅仅在您离开电脑时运行。
    如果您还不确定，可以都去尝试一下！回顶

    屏幕保护程序显示的是什么？
    我们的屏幕保护程序显示当前模拟进程的实时图象。所显示的分子是当前正在被模拟的分子的构造。底部显示的是一千兆分之一秒（飞秒，femtosecond）中的势能增量。蛋白质的图象会以多种显示形式展示出来，使显示效果更为美观。这些显示的蛋白质图象并不含有任何生物学价值；这样的显示是一种诱人的、不占系统资源的表达蛋白质的方式。
    当前有两种显示方式：“空间填充模式”（space-filling）和“球-棒模式”（Ball-and-stick），在“球-棒模式”中，每一个小球表示一个原子，每一根棒子表示一根化学键。在“空间填充模式”中，每一个球体的大小近似于一个原子的大小（核外电子所占的体积大小）。在这两个模式中，碳分子是深灰色的，氢分子是浅灰色的（一些氢原子会被省略），氧分子是红色的，氮分子是蓝色的，硫分子是黄色的。柱型图表示的是当前数据包所完成的比例。回顶

    我的显示器被设置成一段时间后自动关闭。在这种情况下我仍然能运行屏幕保护程序吗？
    节能功能是把显示器屏幕在一段闲置时间后关闭，但是并不影响屏幕保护程序。也就是说，无论显示器是否开启，只要仍然电脑在运行，屏幕保护程序回继续运转并聚集有用的数据。回顶

    屏幕保护本身使用很多CPU资源吗？
    屏幕保护本身在设计之时就是低CPU使用的。即使没有视频加速硬件（OpenGL），屏幕保护本身为了图形输出使用大约5%的CPU能力。如果您的显卡支持OpenGL，屏幕保护本身占用的CPU能力几乎可以是零。回顶

    3D硬件加速会额外帮助屏幕保护程序更快吗？
    3D加速卡在生成某些复杂蛋白质时会有优势。 回顶

    我怎么关闭屏幕保护程序？
    本屏幕保护程序在设计时规定，只有在按下鼠标或使用了键盘之后才会将屏幕保护程序关闭。为了防止用户在无意间关闭屏幕保护。回顶

  • 其它

    标志来自何处？
    我们的项目标志是一种用抽象的手法来表示我们的目标：从蛋白质排序编译到染色体到蛋白质结构。
    左边的双螺旋体表现的是染色体的特征（DNA是一个双螺旋结构）。而右边的箭头表现的是蛋白质的结构（beta sheet结构经常被画做带箭头的带状物）。    回顶

    您是否有专用的网络链接（用来链接官方网站）图片下载？
    这个图象怎么样啊?

    回顶

    在一台计算机上24X7（二十四小时乘以七天，表示不间断）运行F@H一般会耗费多少度电？
    粗略地算，一颗CPU相当于一个60瓦的电灯。这里有一张来自伯克力劳伦斯国家实验室的计算机电源处理报告，同时，您可以在其他参考网站上找到相关的内容。尽管大多数计算机电源的额定功率是250瓦，但是实际功率却小得多。平均算来，一颗奔腾系列的计算机运行时使用45-70瓦电力（我已经通过许多不同的资料来源证实过了）。如果计算机没有休眠模式，运行某一个程序和不运行某一个程序所用电力相同。如果计算机处于休眠状态，它大约使用25瓦的电力。这么算来，一天日夜运行F@H将使用1.1到1.7千瓦时的电力。具体电力价格可以查询供电部门。
    同时，我们建议您可以关闭显示器，这样也能够节约相当多的电力。回顶

    安全问题？
    我们已经为维持安全尽了最大努力。我们的软件只会从斯坦福大学的数据服务器上传和下载数据。数据服务器不会将任何可执行代码传输到您的计算机。实际上，我们的软件比您正在使用浏览器还要安全。
    这怎么可能呢？我们使用了各种方式来检查发送至您计算机的和被传送回我们服务器的2048位数据。如果信号不匹配（输入或输出）程序将抛弃数据而重新开始。另一个软件安全性的衡量因素是更新程度（3.0版本经过了数字签名和PKI），我们保持着最严格的安全可能。
    最后，客户端/屏幕保护程序只能从官方网站下载。我们不允许Folding@Home程序从别的地方下载，也禁止您用这种方式来推广这个软件。回顶

    为什么没有IRIX/Solaris/其它版本？
    我们收到许多关于其他操作系统的客户端程序请求。我们保证，我们将会尽快开发并提供大家下载，也许会是几个星期。现在，我们也在寻找SGI、Solaris等方面的编程高手。总体来说，Cosm libraries可以解决这些问题，那么我们将能发布这些版本。回顶

    您将在软件的最新版本中增加什么功能？
    这张表格包括了未来几个版本可能新增的功能，没有意外的话，部分内容将会在接下来的几天内完成，部分可能需要几星期或几个月来实现。
    如果您还有别的意见，请在支持中心新闻组里写上建议。
    ·在苹果机系统实现屏幕保护和命令行。（看来已经完成了）
    ·在Linux系统上的命令行程序加一个屏幕保护支持。
    ·支持不同的UNIX系统（比如BSD, IRIX, Solaris等）。
    ·在命令行和屏幕保护上改进用户控制。
    ·在屏幕保护上改进密码保护的兼容性。
    ·改进已计算蛋白质的可视化效果。
    ·改进安装过程中的文档。
    ·改进调制解调器、笔记本电脑和其他可间断连接的支持性。回顶


技术中心

了解最新情况清访问英语页面。

·本站提供帮助您的方法：

中文留言板 / 中文论坛

以下内容也许可以帮助您解决您的问题：
1．察看我们在下载页面上的安装说明。如果您正在使用旧版本的客户端程序，请立刻升级。
2．请访问我们的“常见问题FAQ”。
3．另外一个寻求Folding@home帮助的好去处是讨论组。我们的主要讨论组是http://forum.folding-communitry.org，一个以交流为基础的新论坛（始于2002年4月）。我们现在已经不再使用以前Yahoo的功能，请使用新的论坛。
4．Google正在支持Folding@home项目。我们已经和Google的工程师们把Folding程序嵌入了Google工具栏。您可以通过http://toolbar.google.com/dc/aboutdc.html激活Folding@home的工作。您也可以去访问Google的“常见问题FAQ”。最后，如果您在使用Google工具栏的时候出现问题，请联系Google支持中心。对于没有使用Google工具栏的Folding用户，请直接联系Folding。
5．英特尔（INTEL）曾经帮助过我们的工程（“斯坦福/阿兹海默症研究工程”Stanford/Intel Alzheimer's Research Program），但是英特尔已经宣布他们对于分布式计算工程的援助已经结束，他们将不再支持任何分布式计算工程的客户端，当然也包括Folding@home。


Folding@Home 图形版新手指南

2004-5-22 中国分布式计算总站

简介Folding@home是一个研究蛋白质折叠，误解，聚合及由此引起的相关疾病的分布式计算工程。我们使用联网式的计算方式和大量的分布式计算能力来模拟蛋白质折叠的过程，并指引我们近期对由折叠引起的疾病的一系列研究。

详细----- http://www.equn.com/folding/

下载页面http://www.equn.com/folding/download.htm
建议用 Windows 图形版的！

点击 下载

简介：http://www.equn.com/folding是一个研究蛋白质折叠、分解 、聚合及由此引起的相关疾病的分布式计算工程。我们使用联网式的计算方式和大量的分布式计算能力来模拟蛋白质折叠的过程，并指引我们近期对由折叠引起的疾病的一系列研究。

装好后, 看下图设置！

网络设置：不是拨号上网的和不需要代理的可以跳过，按默认设置！

图形界面DIY，打造自己喜欢的……
图形刷新率会增加 CPU 的占用率（虽然是一点点，但推荐图中的设置，除非你为了欣赏图形……）

一般上大家主要设好用户名（USER）和参与队伍编号（teamnumber）就行，日常使用上不用理会，只要经常打开让它运行就行 ！要进一步优化调整的看以下高级设定图解教程！而高级设定也不太复杂，有详细的图解说明！

作者：Simon_Sen


Folding@Home 命令行版用户指南

2004-7-1 中国分布式计算总站

Folding@Home 客户端命令行版用户指南
注: 下面所说是针对 Folding@Home 4.00 而言. 因此这信息是随时变化的。

F@H客户端注意事项：一般情况下您不用管它，您只需下载并运行它就行了。但是，如果您想具体控制F@H的运行，请记住：

各F@H的拷贝必须有其自己的设备ID编号。 如果您从网站下载并全新安装每个F@H，是不会出问题的。 在网络上传出错后请不要手工重试发送WUs。上传出错意味着服务器可能超载，重试会使情况变得更糟。

命令行版客户端命令选项：
-config
允许用户更改他们的设置信息。包括帐户& 小组名称(在统计里所显示的)，在需要连接网络下载/上传WU时是否询问，设置代理服务器，选择喜欢的数据包类型(Folding/Genome)，处理器优先级，CPU占用量(5-100%)，是否使用指令加速，是否考虑截止日期信息和更改设备ID。

-configonly
同上，但设置完后会立即退出而不会开始工作。

-delete x
从数据包列表中删除第#x数据包。只有在当前数据包出现严重的错误，导致客户端无法自动恢复时(比如程序崩溃)才可以使用这个选项。正常情况下不会发生。如果发生了，我们希望您能把导致错误的WU的FAHlog.txt文件发送给我们。

-license
显示最终用户协议。

-queueinfo
显示列表中数据包的相关信息。包括各个数据包的状态（READY/FINISHED/EMPTY），数据包类型（Folding/Genome），来源服务器和数据包接收日期(格林尼治时间)，如果服务器给了截止日期信息同样也会显示出来。

-send x
把第#x结果上传给服务器。上传结果时客户端自动退出(不管上传是否成功)。可以使用"- send all" 发送所有结果。 如果数据包x没有算完，客户端不会上传它，它会自动退出。

-verbosity x

设定输出信息等级，从1到9 (最大)。默认是3 。如果用户想看更加详细的客户端输出信息，可以使用这个选项，如果出现需要向F@H客户端开发小组报告的问题，它会特别有用。

-oneunit
命令客户端在完成当前WU后退出。

-forceasm
命令内核尽量使用SSE/3DNow指令集，既使设备会出现严重错误。

-forceSSE
在AMD处理器上，命令Core_78使用3DNow 指令集而不使用SSE 指令集。

-advmethods
请求下载新内核或WUs。

-local
使用本机文件夹中的配置文件。这个选项不能用于 Linux，但是在运行了多个客户端的 windows 和 Macintosh 上会起很大作用。它命令客户端从当前目录 client.cfg 文件读其设置信息。而不是在 Windows 里的，被注册表指定的安装目录；或是，在 Macintosh 里的，Library/Folding@home 目录。 在 client.cfg 文件里有譬如帐户名，小组名，代理信息，设备ID等信息 。 此参数能保证, 工作不相冲突。 如果您想在一台机器上运行多个 Folding@Home 客户端程序请使用“- local”（您只有在多处理器电脑上运行，它才会起作用 ）。电脑有多少个处理器就创建多少个目录，把“.exe”文件和 client.cfg 文件拷入每个目录，在每个目录里运行“FAH4Console -client -config”为每个客户端指定唯一的设备ID(在高级设置选项里) 。 然后您就可以转到其目录用“- local”参数运行各个客户端了。

-help
显示客户端正在使用的参数然后退出。Linux 专用。

-freeBSD
让那些使用 FreeBSD 的用户在机器上运行 Linux 客户端程序。在我们的FAQ页面上有相关的详细资料，使用这个参数，客户端会自动下载所有 LINUX 系统版本的内核。

Windows 下面的选项只能用于 Windows 客户端。

-pause
在算完和上传完当前数据包以后暂停。允许用户在完成数据包以后，按Ctrl-C关闭，而不会自动申请新数据包。如果您想长期(比如一个假期)关闭您的计算机，或者您想在完成当前数据包后重新安装F@H，那么推荐您使用它。

-service
在服务模式下运行(做为后台程序运行)。这可以使客户端即使检测到当前用户注销也不会退出。如果在客户端没有作为后台程序运行时打开这个选项，那么即使用户注销它也不会自动关闭，将会显示一个“Wait for program to close.”对话框。

作者：vmzy


Folding@Home命令行版本解释

2004-8-19 中国分布式计算总站

推荐用的参数：如果是intel 支持SSE的CPU(Celeron 2后的CPU)可以去掉 -forcesse, Intel / AMD 不支持SSE的CPU也要去掉.(如Celeron I / 旧Duron)。

例如：FAH4Console.exe -local -forceasm -forcesse -advmethods

第一次运行F@H时会有具体的配置问题出现, 看图：

快捷方式运行F@H：

作者：alen


一些Folding@home心得

结果上传失败的解决办法

又是以前那个论坛的好帖子。
    要下载FAH的命令行版本！因为 Folding@Home 一旦传不上，它就会等n天后才传上去（我也不知道到底是几天^0^！）。把下载的fah3consloe文件放入 Holding@Home 所在文件夹！然后在dos窗口里（NT内核系统运行cmd可进入！9x系统在开始菜单里有“dos提示符窗口”）进入 Folding@Home 所在文件夹，输入“fah3console -queueinfo”，可查看有没有没传上的WU（就是前面有“done”的那些）！如果有，而且没过期（info里一般有两个日期，前面是WU下载日期，后面是过期日期）就输入“fah3console -send x”命令把相应的数据包传上去！如果数据包已经过期的话是可以上传的，也会记入积分，但过期上传的结果毫无科学价值！

原著：vmzy 修改：S-Vampire

一些 Folding@Home 心得

    如果不能发送结果包，fah4console 会自动重试。先是每2分钟一次，几次失败以后，它会试着下载新的wu。然后每6小时重新尝试连接一次发送结果。

    如果是G@H的话，你会拿到 tinker。就是进度是 frame 不是%的那种。比较慢一点，但是不会有限期完成的问题。比较适合慢的电脑，比如奔2-300MHz以下的速度。

    如果有可能的话尽量用 ntfs，不要用 fat/fat32。因为如果当机的话fat/fat32会掉包。Windows
xp 可以把 fat/fat32 转换成 ntfs。方法是：运行convert c: /fs:ntfs。需要重新开机。

在 win2000/xp 下最好用 service。

我用的安装包，非常好用，强烈推荐！可以去这儿下载： http://project-2501.net/files/FAH4%20Console%20Installer/FAH4.Console.Installer.v0.32.exe

用法如下：

如果想使用支持HT技术的CPU开多个F@H，则必须至少有一个命令行版！

如果有HT，一个命令行版，这样他们的电脑一直会有50%load，然后用图形版当屏保。或者直接装2个指令版的service。

作点说明：
-forceasm
强迫使用最优化的assemble代码。一般来说Intel的芯片会默认用 SSE/SSE2，AMD的如果用-forcesse也会用sse代码。有时候电脑不稳定，会当机。重新开启后FAH会停止使用SSE。-forceasm告诉FAH一定要用sse。以前因为Fahcore_78有bug，会导致用sse时芯片过热而当机，现在已经没有了，所以是基本无用。

可以通过“开始”--“运行”--输入“cmd”（xp系统）（或“command”9x/2000/Me系统）--然后进入“FAH4Console.exe”所在的文件夹--运行“fah4console -configonly”更改设置。

如果你改过fah4console.exe，你会发现一些没有公布的switches。比如：-betateam -internal -delete 等。-betateam 会给你beta wu，听说很不稳定，比advmethods差很多。

关于 Folding@Home 的几点补充说明,
严重提醒:使用 nVidia 显卡的 FAH用户要注意了, 在图形版上会和 nVidia 的显卡驱动发生 OpenGL 冲突而发生死机等情况, (绘图用的是 OpenGL 加速), 建议使用53.xx或者以上的 WHQL 驱动, 最好不要用 beta 版驱动, 而目前在ATI的各催化剂版本上都没有发现什么情况！另一个解决方法是不用图形版, 使用 Windows 的console(dos)的客户端！
欢迎大家把使用中的情况在论坛发贴反映！

    鉴于 Folding@Home 在代码优化上, sse比3dnow 差不多快一倍!!所以建议 AMD 的 Athlon XP, 新Duron用户使用-forceSSE 参数强制进行sse优化(具体方法看图), 因为鉴于目前出错的几率比较小, 而使用sse参数后比3dnow 的运算速度快差不多一倍 。利>>>>>弊。（thunderbird旧核心出错机会比较高, 请权衡使用）但对于400的wu无效, 因为400的wu 用的运算内核不支持任何优化, 只用最原始的浮点运算 ！

作者：phoen8x Simon_Sen